Submit a request

Help is on the way!

Popular help topics: limitations, embed, watermark

24. What are the system requirements for PollSnack?

In order to view PollSnack.com correctly we recommend Firefox, Google Chrome, or Safari. PollSnack.com will also work on the latest versions of Microsoft IE.
Also, you must have JavaScript enabled and the latest Flash Player version (you can get it from here).